Ruby passenger Gitlab

Oh my we need python on this running nginx stack
apt-get install python-software-properties
add-apt-repository ppa:brightbox/passenger-nginx-testing
apt-get update
If you dont have nginx get it with mongodb etc http://drupal.org/project/boa
apt-get install nginx-full
we already have nginx so we need to throw Ruby at it with RVM
cd /usr/local/rvm/bin
./rvm requirements
copy all this crap and rvmsudo it. (be sure to meet the packages you need not this example)
./rvmsudo /usr/bin/apt-get install build-essential openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion pkg-config
Install ruby, gems and passenger and nginx-module
apt-get install ruby1.9.1
apt-get install ruby1.9.1-dev
sudo gem install passenger
sudo passenger-install-nginx-module
This breaks our nginx :( need to recompile and find all dependencies....

 

Hessen Kasselstraat 8
5615 SM Eindhoven
phone: +316-81888456